Pixel 4a No Wifi Calling

  • 1 August 2021
  • 9 replies

Badge +1
  • Participating Frequently
  • 6 replies

I have 4 Pixel 4a’s on my account, yet one will not activate Wifi Calling.  It receives an “Error Identified contact us at 611” error message.  

The BYOD Cricket List Found Here states that the Pixel 4a is fully supported.  Support claims the Pixel 4a does not support Wifi Calling and that list and phone compatibility is subject to change at anytime. We tried a new SIM and it still received the same error message. 

If I take my wife’s SIM out and stick my SIM card in the phone, Wifi Calling will work.  I think it is a Cricket issue, but they are claiming the Pixel 4a is an unsupported phone, yet my other 3 Pixel 4a’s on the account have no issues with wifi calling.

Any ideas or suggestions?


9 replies

Userlevel 4
Badge +5

Hello @lvpre! Welcome to our Cricket Community Forum and thank you for your post. We are happy to further investigate this issue with our IT team. For further assistance, 

please reach out to our support team on Facebook ( or Twitter (@cricketsupport).


Badge +1

I did reach out to them on Facebook and they told the Pixel 4a isn’t officially supported and gave the response I posted above.

I’m just wondering why they have it on the list as supported and my other Pixel 4a phones work.  It also works for a bit after putting her SIM into a Moto e5 Cruise and then into her Pixel 4a.  I just think her Pixel 4a IMEI is conflicting with the Cricket database.


Userlevel 3
Badge +4

@lvpre They got another list on their website that shows devices that are Wi-Fi calling capable, and it does not look like the Pixel 4a or any pixel is in there. Also says Wi-Fi calling won’t work on Android phones if not purchased at Cricket, but I heard of some people getting it to work, so it may just be a not guaranteed thing. 


WiFi calling


I am having the same issue on Pixel 4a with Android 11. WiFI calling works on the day I insert the SIM and stops working the next day and cannot get it to work after that. I have a feeling Cricket validates IMEI every 24 hours and they remove the feature if it is not in their database or something. I made sure that my phone number is tied with Pixel 4a IMEI but still no use. There should be a way to fix this on Cricket side as it works for a day but their support is pathetic, they just say any Android is not supported unless you buy from them.

This is so frustrating I have spent few hours explaining their website  OP stated lists as certified but they deny it. 


@cdexter  you are comparing 2 completely different lists.  The one you linked is for wifi calling phones sold by cricket.  The one linked in the first post is for BYOD and there are pixels listed there and if you look at the little numbers by the phone and refer to them at the bottom of the page it says wifi calling.  

I have a s20 FE 5G ( unlocked sm-g781u1) that is on that list and after hours on with chat I have given up.  Pretty sad if you put any other att mvno Sim that has wifi calling it works perfectly on all of these phones.  It's just cricket wanting people to buy phones from them.  Why they don't take the list down is beyond me.  We are moving 4 lines out over this BS and cricket doesn't care at all.  


Thanks for the information, I will try to figure it out for more. Keep sharing such informative post keep suggesting such postadvancedmd


I have been dealing with this issue for almost a month now and today I finally was able to get it sorted out.  To anyone having this problem of no WiFi calling on a phone that is on the supported list reach out on Twitter to @CricketSupport 

it took a lot of back and forth and they ended up escalating it to a higher tier support and they called me back and had me try it again and it was fixed.  Apparently they have to update something in one database that should have been there but wasn’t and that’s why it wasn’t working.  Good luck to all.   


Here are some reasons why WiFi calling may not be working: The WiFi calling setting is turned off in your phone's settings myaarpmedicare. You don't have a WiFi network connection. To prevent using a cellular network to make or receive calls, put your phone in airplane mode and make sure WiFi is on.


@earnest_06  Did you even read the post or any of the comments?  If you read even one of them you would realize that WiFi calling will not activate.  It’s not a setting on the phones.  Everyone would absolutely love it if it was as easy as you made it seem to be.