GS6 bootlooping

  • 17 November 2018
  • 3 replies
  • 16 views

  • New Participant
  • 2 replies

My husband's GS6 keeps boot looping, may stay up for a minute or two but usually doesn't get fully past the Samsung logo on startup.  The day this started he showed me that the phone had a blue screen with Downloading on it.  He did not initiate this.  I later found out that it's a special screen you have to press 3 keys to get to!  He didn't do that!  So maybe it was a bad update that came OTA?? 
Anyhow, have tried to wipe cache, have tried factory reset, and no help.
I tried to connect to Smart Switch but it said something like device incompatible. 
Not sure if firmware problem, or hardware problem, or ?
Any suggestions?  He had to go ahead and get a new phone but it would be nice if we could get this working as a backup.


3 replies

Userlevel 3

@GJC, it is possible it could of been a bad batch of software updates.  We recommend reaching out to Samsung to see what they recommend as a fix. 

Thanks, chatted with Samsung & they suggested I contact my carrier!   :)


I'm thinking of stopping by Best Buy to see if they have a Samsung person there who can help me.  Not sure if they'll help since it's out of warranty, but might be worth a try.

Update:  It was overly optimistic to think Best Buy could help.  All they did was give me an address for a regional Samsung service center.

Still wondering why Smart Switch doesn't recognize the phone.  If some firmware update caused the problem it seems like that would be a good way to reimage it?

Reply