Using phone from Xfinity

  • 27 November 2018
  • 4 replies

I ported over to an Xfinity phone, Moto e5 play. Since switching I have two issues, one major.

Major: seems like my Wi-Fi settings have not switched to cricket. I still have the option to connect to Xfinity hotspots. Even though I have this setting turned off, my wifi will still try to connect to the XFINITY hotspot and will show that I'm connected, although obviously I'm not. But this has the effect of disconnecting my data. So that's really annoying. How can I get this phone to switch really over to cricket Wi-Fi? I understand I'm supposed to have the option for Wi-Fi calling also, which is not in my settings.

Second thing is that I do not have a cricket voicemail widget so I do not know when someone has left me a voicemail. How do I get that?


4 replies

I got my phone from Cricket (Moto G7 Supra) and from day 1 it has this problem:   From time to time it launches a screen that wants me to sign into Xfinity or become am Xfinity customer.  The Screen has both the Cricket Wireless and Xfinity logos.     I think it might be being triggered by proximity to Xfinity hotspots but that's just a guess.    I don't know what brings it up.   I have poked around in settings and I don't see anything about Xfinity.  There is no Comcast or Xfinity app listed on my phone.   I called Cricket and they were clueless on this.  Anyone know how to get rid of this?

Userlevel 4

@Pattiq22 Good morning, I was able to find some steps that may help with the Auto connect feature on the device. Hopefully these steps work for you:

Here's how to stop your Samsung phone from auto-connecting to Xfinity WiFi hotspots:

  1. Go to Settings > Connections > WiFi > Advanced

  2. Toggle Auto-Connect to Xfinity WiFi to off

Note: Turning off Auto-Connect to Xfinity WiFi will not prevent your Samsung phone from automatically connecting to your home WiFi and other saved networks. If for some reason your phone is still connecting to Xfinity WiFi hotspots after you’ve turned off Auto-Connect to Xfinity WiFi, try this:

  1. Go to Settings > Connections > WiFi > Advanced > Smart Network Switch

  2. Make sure Smart Network Switch is off

Thanks, I was able to find the visual voicemail app.
Regarding wifi, I was hoping for a way to get the Xfinity wifi just out of settings AND get the wifi calling feature. It is NOT convenient at all to have to turn wifi off every time the phone tries to connect to Xfinity. I have to do this multiple times a day if I'm driving. Many times I forget to turn wifi back on then and end up using data needlessly. Is there just no way to get this phone to have cricket's WiFi settings? If not, just say so, but I sure wish I had known about these issues beforehand.
Userlevel 4

@Pattiq22 Hi there! Thank you for visiting and posting on the Cricket Community Forum! Below I provided a link for the options on setting up basic or  the visual voicemail app for the device. For the Wi-Fi issues I would suggest swiping the status bar down, then tap > Network & Internet > Wi-Fi to turn Wi-Fi off. Hopefully this work for you.