Wifi calling doesn't work on Samsung Galaxy A11

  • 13 August 2020
  • 2 replies

I just bought a new Samsung Galaxy A11 phone yesterday from a Cricket store. I cannot get Wifi calling to work. When I try to turn it on from the top control panel or from the settings page, there is a message at the bottom that says "Loading, this may take a few moments..." and a circle that spins away. Also, the banner where the time, Cricket, and the Wifi and battery indicator are shown turns from black to grey at the top. It's as if there is an app running, but there is no content shown on the screen in the middle, just the bottom message, and the top grey banner.

I would like to add that my two previous phones from Cricket both had Wifi calling and they worked fine with my router. One was an LG phone and the other was a Motorola that I bought just a few months ago but dropped (AGH!!!). I'm not sure what to do at this point, as there is no support page for this device on the Cricket website yet. 

Thank you all for your time. 


Best answer by Jerdog79 5 September 2020, 05:23

View original

2 replies

Userlevel 3


Thank you for reaching out.  Wifi calling is an available feature for your device.  

We would like to look into this further for you. Please reach out to our support team on Facebook ( or twitter (@cricketsupport) with the details of your issue.


I will mark this as solved, since the September quarterly update from Samsung and Cricket, my phone's WiFi calling function now works properly. Thank you all for your time.