cancel
Showing results for 
Search instead for 
Did you mean: 
normajp57
A-List Star

Not receiving MMS texts but I can send them

hello,

 

I haven't been receiving MMS texts, like group chats or pictures.

 

I can send but not receive.

 

I reset my APN settings, it would work but eventually stop again.

I changed the SMS app to FB Messenger and Textra, same thing.

I restored my phone and same thing.

 

Android motorola e5 cruise

 

thanks

4 Replies

Re: Not receiving MMS texts but I can send them

I have the same issue with my wife's e5 Supra starting over the weekend. Please let me know if you get it resolved.

0 Kudos
normajp57
A-List Star

Re: Not receiving MMS texts but I can send them

I wonder if it's a Motorola issue or something?

 

They gave me a new APN settings but then it prevented from sending, too.

 

Waiting for them to get back to me after they look into it further.

0 Kudos
sunnyand7777
A-List Star

Re: Not receiving MMS texts but I can send them

I found 2 solutions. (1) Turn off your WIFI just before or when downloading an attachment, ie photo, etc. Afterward, turn wifi back on. Worked well, just a pain to do it as well as remembering to turn it back on!
(2) Switch to Google's Messages app. I did this in 8/2019 when the newest version came out. Now, it works perfectly and do not have to do the off and on either wifi any longer!
0 Kudos
sunnyand7777
A-List Star

Re: Not receiving MMS texts but I can send them

Just in case others may still be having this problem, I wanted to give a new update.  I downloaded & installed the (blue) Messages app by Google (from the Google Play Store. Then, I disabled the standard Samsung Messages app (orange/red).  I use the blue Messages app as my primary/system app. It has a setting for allowing both SMS and Wifi. Selecting to allow MMS attachments to download solved the problem!  I felt like I had discovered gold when this actually worked.  I hope those of you still fighting with this dilemma find this solution as helpful as I did.  Good luck & Thank You, Google!

0 Kudos