VoLTE Service disabled after software update?

Badge +1

Sometime around the beginning of March, I purchased a factory unlocked Galaxy S8. Prior to the purchase, I checked with cricket to ensure that the phone would be compatible with their service - I was assured that it would. Phone arrived, and I set it up with no issue - or so I thought. The next nay someone informed me that they had been trying to call me but my phone went straight to VM.

A bit odd, I thought, and attempted to call them...and the call would not go through. All Data services were working, the phone showed connected to the cricket network, but I could not make calls. 

I tried everything I knew to do, reset settings, restarted the phone, etc, to no avail and so I contacted customer support. After literal hours or trying this setting and that setting, the support person informed me that my phone was NOT compatible with cricket service and I’d have to buy a new one. 

But I verified that it was compatible? To which they replied, “Oh, yes, the phone is compatible with our service, but it won’t WORK.”

Do what? After going round and round on this several times, and being assured that the phone was INDEED compatible, but it still wasn’t going to work, I finally received this bit of information - although the phone itself was compatible and was capable of the necessary HD Voice and VoLTE services, because it was a factory unlocked device and not a cricket device, they would not provision it to work on the network. I was advised to purchase either a Cricket or At&t branded device.

Ok, back to square 1. Luckily, I was able to return the S8, and after much research, I purchased an At&t factory locked Galaxy S9+.

It arrived and I set it up without hiccup. It worked perfectly out of the box.

Until today.

This morning, I received notification that there was a software update available. I postponed it. I made phone calls, texts, etc. Everything was working swimmingly.

About 2 PM, the update notification reappeared, and whatevs, I had time, so I told it to install. 

Phone updated, went on about my business...until about 4 pm, when I went to make a phone call.


Feeling a sense of dread and deja vu, I tried to make the call again. Still nothing. I called someone else. Nothing. As soon as I hit the call button, it showed call ended.

And so, once again, I spend hours  chatting with customer support. They tell me to change this setting, that setting, etc. Nothing works.

Finally, I get the answer, “I’m sorry, it appears that your BYOD phone is not supported by our network.”

I explain (for the third time) that it was IN FACT working on their network until the software update today.

Oh, well in that case, lets try changing THIS setting. (nope)

Again, “I’m sorry ma’am but I see that you have a BYOD phone, and it is not supported by our network.” 

Honey, I’m getting tired of explaining this….but again I explain that it WAS WORKING until I did the software update. 

“OH! Well then the firmware was updated, and caused it not to work! “

No, really? Brilliant deduction Sherlock!

Finally, I was advised to perform a factory reset (which I had already decided to do, prior to the advice….)

So I backed it all up, factory reset dice.

CS gave up and told me that I have no option but to purchase a new (Cricket branded) device, or do without call service “until a patch is released to fix the problem”.


I’m angry. They offer NOTHING, no solution, not even a discount, except to offer me a cheap cricket phone for $40 that will do nothing I need it to do - except make calls. This is twice I’ve spent hundreds on a device only to have it bricked for no reason. 

This phone has the capability to make HD VOICE and VOLTE calls. I had the ability to turn wifi calling on and off - until this software update, where all of that suddenly disappeared. The whole “Enhanced Calling” menu just disappeared from my phone settings! I can dial *#*#4636#*#* and see that VOLTE is disabled...and no ability to enable it.

We’ve been cricket customers for years now, had no problems, loved the service, but THIS IS ABOUT to send me over the edge!!!


Has ANYONE found a workaround for this?? I’m open to flashing new software, but I can’t find for sure which software will work.

I hate Apple phones, but I have to say, my husband and daughter have iphones that are much older than my S9, and they are working just fine! And I’ve seen people with Galaxy s20s that have had this same issue, so it’s not just the fact that the phone is 4 years old...



Best answer by CD_Cricket 4 May 2022, 22:11

View original

2 replies

Badge +4

Hi @DavisFam, We're sorry to hear of your experience with Cricket Wireless. Have you changed the SIM card in your device? In some cases the SIM card is the issue.  If you still need assistance, we are here to help. Feel free to send us a PM with your wireless number, and name on the account.


Yes, your existing 4G smartphone can be used to experience Airtel VoLTE services as long as you have completed the software upgrade for your ...